Curieux, j'ai voulu tester Wix, un outil pour créer un site par glisser-déposer.
Je n'ai testé que rapidement l'outil, mon avis est donc biaisé.

Mais, premièrement, le code généré est dégueulasse :

<div style="text-align:center;overflow:hidden;" id="ppPrt4-6xh_MediaTopPage_PhotoPost__0_0_0_0_ReadMoreBtnlink" class="s14link" data-reactid=".0.$SITE_ROOT.$desktop_siteRoot.$PAGES_CONTAINER.1.1.$SITE_PAGES.$czwt.1.$ppPrt4-6xh.0.0.$child.$0.$0.$0.0.$0.$child.$1.1.$1.$9.$1.0.$0.$0.0">
  <span id="ppPrt4-6xh_MediaTopPage_PhotoPost__0_0_0_0_ReadMoreBtnlabel" class="s14label" data-reactid=".0.$SITE_ROOT.$desktop_siteRoot.$PAGES_CONTAINER.1.1.$SITE_PAGES.$czwt.1.$ppPrt4-6xh.0.0.$child.$0.$0.$0.0.$0.$child.$1.1.$1.$9.$1.0.$0.$0.0.0" style="line-height: 35px;">
      Lire la suite
    </span>
</div>

(il y a une bonne vingtaine de parents imbriqués avant cet élément)

Et, quand tu déplaces des blocs, ça fait un positionnement absolu, comme ça : left: 15px; position: absolute; top: 441px; width: 187px; height: 85px;.

Donc tu dois faire une version Ordinateur et une version Mobile du site, bof. Et je me demande comment ça fonctionne sur tablette.

L'outil est lent et fait ramer mon ordinateur (je n'ai pas un super ordinateur, mais ça ne justifie pas une telle lenteur).

J'ai créé un simple article avec une image mais lorsque j'ouvre la page de l'article dans le rendu final, du texte vient par dessus l'image (et il y a des problèmes similaires ailleurs).

µBlock Origin, sur un site basé sur un template à peine modifié (j'ai déplacé deux éléments et ajouté un article), me recense 39 pisteurs.

Bref, ils ont beau faire de la publicité (je la vois sur YouTube), eh bien l'outil n'en reste pas moins déplaisant.

Si vous avez un avis, n'hésitez pas à le partager.

Commentaires
sodimel Le 12 octobre 2019 à 19h48
coucou grâce à toi je ne vais pas acheter de pack wix, merci ^^